cannott run on lubuntu 18.04 64bits curses

New to FreeBASIC? Post your questions here.
ptitjoz
Posts: 25
Joined: Jun 24, 2017 8:10
Location: France, centre
Contact:

cannott run on lubuntu 18.04 64bits curses

Postby ptitjoz » May 05, 2018 15:07

Hello
i installed fbc

Code: Select all

fbc --version
FreeBASIC Compiler - Version 1.05.0 (01-31-2016), built for linux-x86_64 (64bit)
Copyright (C) 2004-2016 The FreeBASIC development team.

when I try to compile a sample hello.bas
print "hello.bas" i have this message (french) :

Code: Select all

fbc hello.bas
ld : ne peut trouver -lncurses

do yo have an idea ?

Regards
lizard
Posts: 358
Joined: Oct 17, 2017 11:35
Location: Germany

Re: cannott run on lubuntu 18.04 64bits curses

Postby lizard » May 05, 2018 15:32

ptitjoz wrote:do yo have an idea ?

Whenever a lib is missing go to terminal and do

Code: Select all

sudo apt-cache search libncurses

or similar.

This shows a list of related packages. Mostly one with the ending "dev" is the right.

Maybe "libncurses5-dev" is the right in this case.

then try

Code: Select all

sudo apt-get install libncurses5-dev


if it not works uninstall and try another package.
Last edited by lizard on May 05, 2018 15:42, edited 3 times in total.
MrSwiss
Posts: 2480
Joined: Jun 02, 2013 9:27
Location: Switzerland

Re: cannott run on lubuntu 18.04 64bits curses

Postby MrSwiss » May 05, 2018 15:33

You can find all required answers, in the documentation:
CompilerInstalling
CompilerRequirements
ptitjoz
Posts: 25
Joined: Jun 24, 2017 8:10
Location: France, centre
Contact:

Re: cannott run on lubuntu 18.04 64bits curses

Postby ptitjoz » May 05, 2018 15:51

lizard wrote:
ptitjoz wrote:do yo have an idea ?

Whenever a lib is missing go to terminal and do

Code: Select all

sudo apt-cache search libncurses

or similar.

This shows a list of related packages. Mostly one with the ending "dev" is the right.

Maybe "libncurses5-dev" is the right in this case.

then try

Code: Select all

sudo apt-get install libncurses5-dev


if it not works uninstall and try another package.


Thank you. I have installed libncurses5-dev only an now FPC works !
Regards

MrSwiss wrote:You can find all required answers, in the documentation:
CompilerInstalling
CompilerRequirements

thanks you for the links !
Regards
D.J.Peters
Posts: 7419
Joined: May 28, 2005 3:28

Re: cannott run on lubuntu 18.04 64bits curses

Postby D.J.Peters » May 05, 2018 16:00

ptitjoz wrote:I have installed libncurses5-dev only an now FPC works !
Do you tried the Screen or Screenres command also ?
If it fails you need some more dev packages.

libx11, libxext, libxpm-dev, libxrandr, libxrender

note it must be the libxxx-dev packages and the right for your OS 32 vs 64-bit.

Joshy
lizard
Posts: 358
Joined: Oct 17, 2017 11:35
Location: Germany

Re: cannott run on lubuntu 18.04 64bits curses

Postby lizard » May 05, 2018 16:35

You can try the installation srcipt from here

viewtopic.php?f=5&t=26349&p=246714#p246714

Then all dependencies are installed automatically, including libncurses5-dev.
marcov
Posts: 2501
Joined: Jun 16, 2005 9:45
Location: Eindhoven, NL
Contact:

Re: cannott run on lubuntu 18.04 64bits curses

Postby marcov » May 05, 2018 18:41

ptitjoz wrote:
Thank you. I have installed libncurses5-dev only an now FPC works !


(Oh, dear, FPC is a whole different forum)
ptitjoz
Posts: 25
Joined: Jun 24, 2017 8:10
Location: France, centre
Contact:

Re: cannott run on lubuntu 18.04 64bits curses

Postby ptitjoz » May 06, 2018 20:11

sorry i put fpc in place of fbc
I like too FPC and I try FBC
Regards

Return to “Beginners”

Who is online

Users browsing this forum: No registered users and 1 guest