Function pointer

Windows specific questions.
deltarho[1859]
Posts: 1014
Joined: Jan 02, 2017 0:34
Location: UK

Re: Function pointer

Postby deltarho[1859] » Feb 24, 2018 15:45

It would seem that the issue had been solved at some point. I have a two pane file manager and more than one directory with this project; one is the main directory and the other is a test bed directory. The exe was running from the main directory and the test file is in there too. The same test file is in the test bed directory. The encrypted file was being successfully created in the main directory but the test file in the test bed directory was not being encrypted, obviously, and that is what I was looking at after spending a few days in that directory just testing the AES component. Basically I am too organised for my own good or senile decay is definitely starting to 'set in'.

sancho3, fxm and dodicat thank you very much for your great help and especially fxm who got as close to the action as I did and kept pushing ideas at me. I have learned a lot from this exercise and had not seen anything like that long Cast before. I have found casting the most difficult aspect to grasp. I go through periods when I think that I have finally cracked it and then you guys come up with a mind boggling statement like that one.

Here is what all your hard work has given me. Don't take any notice of the timing - the file was coming out of the filecache. The application has been renamed. If that does not turn people off - nothing will.

Image

and here are the options we now have.

Image


Thanks again. <Very big smile>

Added: This was running much faster in 64 bit. Then I tried encryption and got a task dialog advising of a 'Loading failure' with 'Failed to load EncDecStretchCNG.dll'. Well, I would, wouldn't I? Yep, it is senile decay. <laugh>

Return to “Windows”

Who is online

Users browsing this forum: No registered users and 1 guest