install_libs.sh for FB and more

Linux specific questions.
lizard
Posts: 410
Joined: Oct 17, 2017 11:35
Location: Germany

install_libs.sh for FB and more

Postby lizard » Jul 01, 2018 18:13

This script installs many libs needed for FB examples and others on Mint and Ubuntu.. Just make it executable and run with "./install_libs.sh". Tested on Mint Cinnamon 18.2.

Code: Select all

#!/bin/sh
# install_libs.sh

# installs many libs needed for FreeBasic 1.05 examples
# under Mint 18.3 or other linux from ubuntu family
# simply from repository

# if geany spits a error message like "cant find -l..." then
# find packages in terminal with
# apt-cache search ... (or lib...)

# comment out what is not wanted with #

echo
echo " Installing Libs for FreeBasic 1.05 Examples and others"
echo " in Mint 18.3 and other Ubuntu"
echo

# cleanup before
sudo apt-get update

# install all the libs
sudo apt-get install libcairo2-dev libgoocanvas-dev                       # cairo, goocanvas
sudo apt-get install libgtk2.0-dev libgtk-3-dev libgtksourceview-3.0-dev  # gtk+
sudo apt-get install libgtk-3-doc libgtk2.0-doc devhelp                   # optional for gtk+
sudo apt-get install libfreeimage-dev                                     # loads many graphic file formats
sudo apt-get install liballegro4-dev liballeggl4-dev                      # allegro 4
sudo apt-get install libsdl1.2-dev                                        # graphics lib
sudo apt-get install libgd-dev libdevil-dev libdevil1c2                   # graphics lib
sudo apt-get install libopenal-dev libalut-dev                            # plays .wav files
sudo apt-get install libtre-dev                                           # regex support
sudo apt-get install libogg-dev libvorbis-dev libasound-dev               # for fbsound
sudo apt-get install libmad0-dev libdumb1-dev                             # for fbsound
sudo apt-get install libsqlite3-dev libpq-dev                             # database support, postgresql

# swisseph support
sudo apt-get install libswe-dev libswe-doc swe-basic-data                 # swisseph and docs
sudo apt-get install libswe0 swe-standard-data                         #  .so and ~ 44 MB data files for swisseph

# install grub customizer if wanted
sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

# either allegro 4 or 5 can be installed at the same time
# sudo apt-get install liballegro5-dev                                    # allegro 5

# cant find libs for
# cgui, bass, fmod

# other libs mostly must be downloaded manually, often commercial or
# outdated, so we not really need them

echo
echo " Installation finished"
echo


To be continued.

Return to “Linux”

Who is online

Users browsing this forum: No registered users and 3 guests