Can not Compile on CentOS 5.10

Linux specific questions.
Gablea
Posts: 1049
Joined: Apr 06, 2010 0:05
Location: Northampton, United Kingdom
Contact:

Can not Compile on CentOS 5.10

Postby Gablea » Aug 16, 2014 19:15

Hi All,

I have installed FreeBASIC onto my CentOS 5.10 laptop and I am getting the following message
ld: cannot find -lXext

but when I install the package I get the message saying it is already installed

can someone please help me as I am a complete newbie to Linux
TJF
Posts: 3486
Joined: Dec 06, 2009 22:27
Location: N47°, E15°
Contact:

Re: Can not Compile on CentOS 5.10

Postby TJF » Aug 17, 2014 12:44

Did you install the development version (-dev) of the library?
Gablea
Posts: 1049
Joined: Apr 06, 2010 0:05
Location: Northampton, United Kingdom
Contact:

Re: Can not Compile on CentOS 5.10

Postby Gablea » Aug 17, 2014 17:10

i've sorted it as I moved to Ubuntu 12.4 :)
nymair
Posts: 3
Joined: Sep 16, 2014 13:08

Re: Can not Compile on CentOS 5.10

Postby nymair » Sep 18, 2014 13:00

CentOS 5.10 is not a problem. I have compiled FB 1.00 successfully on CentOS 5.9, the process of compilation is very smooth.
tinram
Posts: 88
Joined: Nov 30, 2006 13:35
Location: UK

Re: Can not Compile on CentOS 5.10

Postby tinram » Sep 30, 2014 22:45

@nymair
Yes, I agree.

On my CentOS 6.5 32-bit, the following enabled FBC, FBC-GCC, and GUI-executable creation:

Code: Select all

cd <extracted_directory>
sudo ./install.sh -i
sudo yum install gcc
sudo yum install ncurses-devel.i686 libX11-devel.i686 libXext-devel.i686 libXpm-devel.i686 libXrandr-devel.i686
Gablea
Posts: 1049
Joined: Apr 06, 2010 0:05
Location: Northampton, United Kingdom
Contact:

Re: Can not Compile on CentOS 5.10

Postby Gablea » Sep 30, 2014 23:43

I am not sure what i am doing wrong but I can not still get compile on Centos

I have installed the following
gcc
libstdc++-devel
ncurses-devel
libX11-devel
libXext-devel libXpm-devel
libXrandr-devel
libXrender-devel
libstdc++-static
binutils
binutils-devel

when I do this fbc npos.bas I get this message

fbc: error while loading shared libraries: libtinfo.so.5: can not open shared object file: No such file or directory

am i missing something or have i broke it? I have installed Version 1.00.0 in Linux CentOS
counting_pine
Site Admin
Posts: 6174
Joined: Jul 05, 2005 17:32
Location: Manchester, Lancs

Re: Can not Compile on CentOS 5.10

Postby counting_pine » Oct 01, 2014 3:34

I'm not an expert, but from a quick search, a missing libtinfo.so.5 seems to be a common problem on CentOS 5, so it's probably nothing you or FB are doing wrong.
TJF
Posts: 3486
Joined: Dec 06, 2009 22:27
Location: N47°, E15°
Contact:

Re: Can not Compile on CentOS 5.10

Postby TJF » Oct 01, 2014 6:24

The run-time loader cannot find the binaries of library libtinfo.

On Debian systems libtinfo is included in the libncurses package. I guess on CentOS it's a separate package. Just try to install libtinfo-dev (or libtinfo5-dev, or the run-time package without the -dev).

Return to “Linux”

Who is online

Users browsing this forum: No registered users and 1 guest