gpp 9.10 upgrade strange error compilation

DOS specific questions.
Cpcdos
Posts: 207
Joined: Mar 06, 2013 13:52
Location: France - LYON 69003
Contact:

gpp 9.10 upgrade strange error compilation

Postby Cpcdos » May 19, 2019 10:59

Hi,

My project use GCC.EXE and GPP.EXE for create libs and FreeBasic for compile all in an .exe

On delorie FTP ftp://ftp.delorie.com/pub/djgpp/current/v2gnu/


I would like to upgrade my gpp 7.2 and gcc 7.2 TO --> gcc 9.10, and gpp 9.10. I've merge/remplace manually bin, includes ... directory,
i've every do this operation since old gcc and gpp 4, 5, 6...

But i've this strange problem :
Image

GCC works ! I've isolated problem, it's when i merge GPP 9.10 BIN files and i compile, i've this errors.


If someone have encountered this problem? Otherwise i will keep previous version, but it's psychologically complicated ahah

Best regards,
Sebastien
marcov
Posts: 2767
Joined: Jun 16, 2005 9:45
Location: Eindhoven, NL
Contact:

Re: gpp 9.10 upgrade strange error compilation

Postby marcov » May 21, 2019 8:19

The errors is in .s files, so to me it looks like an assembler problem. So either also upgrade you binutils, or FB generates something that results in assembler that would not be generated by just C code.

Return to “DOS”

Who is online

Users browsing this forum: No registered users and 17 guests