Why is the forum not secure?

For other topics related to the FreeBASIC project or its community.
ganache
Posts: 38
Joined: Aug 04, 2016 9:25

Why is the forum not secure?

Postby ganache » Jun 20, 2017 9:25

I have noticed that the FB forum (ie the website) is not secure. It says so in the address bar.
The other FB forums such as the German language www.FreeBASIC-Portal.de or www.qbasic.at use a secure connection.
(If you look at the protocol in the address bar it says https:\... rather than http which is the case with this site.)
It may not be a huge issue but I do believe that people would feel safer if this could be addressed.
St_W
Posts: 1467
Joined: Feb 11, 2009 14:24
Location: Austria
Contact:

Re: Why is the forum not secure?

Postby St_W » Jun 20, 2017 10:33

The warning is shown when you are accessing this forum using an unencrypted HTTP connection rather than encrypted HTTPS. Additionally recent versions of Firefox display a warning when logging in as the credentials are not transferred in a secure manner that way. This is usually not a big issue when you are accessing the forums via your private internet connection at home, but you shouldn't log in to the forums that way when you're using a public internet connection like e.g. a public WiFi hotspot.

To fix it simply use the following URL:
https://freebasic.net/forum/
(instead of http://freebasic.net/forum/ - note the https instead of http)
St_W
Posts: 1467
Joined: Feb 11, 2009 14:24
Location: Austria
Contact:

Re: Why is the forum not secure?

Postby St_W » Jul 31, 2017 19:32

@Admins:

Could the forum be configured in such a way that it redirects to the secure (HTTPS) site by default?

(btw, this topic better should have been in the "Community Discussion" section; maybe it can be moved?)
owen
Posts: 512
Joined: Apr 19, 2006 10:55
Location: Kissimmee, FL
Contact:

Re: Why is the forum not secure?

Postby owen » Oct 12, 2017 12:41

in prep to donate fbcadcam dot com,net,org to fb community i have been cleaning up the house if you will and for the dot net (for the forum) i ordered an SSL and had the same issues to force https. this is how i think i manged to do it, by setting the dot htaccess file(s) in dot net root and forum directory and some forum sub directories to:

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteCond %{HTTP_HOST} ^fbcadcam\.net$
RewriteRule ^(.*)$ https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
RewriteCond %{HTTPS} off
RewriteCond %{HTTP_HOST} ^www\.fbcadcam\.net$
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Return to “Community Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest