The new website

For other topics related to the FreeBASIC project or its community.
jevans4949
Posts: 1156
Joined: May 08, 2006 21:58
Location: Crewe, England

Re: The new website

Postby jevans4949 » Jan 08, 2013 11:10

Only 2-3 seconds here (outer London, 3km from exchange over copper and AOL) to return a page, which is about what I expect for anything.
fxm
Posts: 10046
Joined: Apr 22, 2009 12:46
Location: Paris suburbs, FRANCE

Re: The new website

Postby fxm » Jan 08, 2013 11:43

jevans4949 wrote:Only 2-3 seconds here (outer London, 3km from exchange over copper and AOL) to return a page, which is about what I expect for anything.

It depends on the time. Right now precisely, it works pretty well.
But three hours ago, it was completely blocked (during more than an hour).

A quarter of an hour later, again a cut of few minutes:
Admin, it would be interesting to ask the question to phatcode (Plasma)?
D.J.Peters
Posts: 8203
Joined: May 28, 2005 3:28
Contact:

Re: The new website

Postby D.J.Peters » Jan 08, 2013 21:45

Last two nights (in germany) i got many timeout errors from the forum.

Joshy
fxm
Posts: 10046
Joined: Apr 22, 2009 12:46
Location: Paris suburbs, FRANCE

Re: The new website

Postby fxm » Jan 09, 2013 13:37

Since 24 hours, it works fairly well, hope it lasts!
Admin, to your knowledge, something has it been done or reported at your site or the site hosting?
counting_pine
Site Admin
Posts: 6237
Joined: Jul 05, 2005 17:32
Location: Manchester, Lancs

Re: The new website

Postby counting_pine » Jan 09, 2013 17:11

It might be search bots. Yahoo has been on our forums as recently as 6 Jan.
I think our robots.txt file may have been edited recently to prevent this, so there may have been a crippling flood of traffic from Yahoo, and then plasma or someone may have stepped in.
D.J.Peters
Posts: 8203
Joined: May 28, 2005 3:28
Contact:

Re: The new website

Postby D.J.Peters » Jan 29, 2013 22:42

to day i got 10 times ...
forum wrote:Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@freebasic.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
fxm
Posts: 10046
Joined: Apr 22, 2009 12:46
Location: Paris suburbs, FRANCE

Re: The new website

Postby fxm » Jan 29, 2013 23:15

Same behavior >> 10 times!
counting_pine
Site Admin
Posts: 6237
Joined: Jul 05, 2005 17:32
Location: Manchester, Lancs

Re: The new website

Postby counting_pine » Feb 27, 2013 5:37

Something seems to have gone wrong in the wiki!
Every wiki page (e.g. /wiki/FBWiki) is displaying many "deprecated" warning messages, e.g.
Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/fb/public_html/wiki/wikka.php on line 1418

I am speculating that perhaps the server's version of php has been upgraded or something?
anonymous1337
Posts: 5494
Joined: Sep 12, 2005 20:06
Location: California

Re: The new website

Postby anonymous1337 » Feb 27, 2013 14:52

Looks like someone needs to update the php.ini file to hide deprecated errors... ex:

Code: Select all

error_reporting = E_ALL ^ (E_NOTICE | E_DEPRECATED)

E_DEPRECATED wasn't introduced until v. 5.3.0. There's also E_USER_DEPRECATED, just in case the utility is throwing errors using trigger_error()
fxm
Posts: 10046
Joined: Apr 22, 2009 12:46
Location: Paris suburbs, FRANCE

Re: The new website

Postby fxm » Feb 28, 2013 12:01

counting_pine wrote:Something seems to have gone wrong in the wiki!
Every wiki page (e.g. /wiki/FBWiki) is displaying many "deprecated" warning messages, e.g.
Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/fb/public_html/wiki/wikka.php on line 1418

I am speculating that perhaps the server's version of php has been upgraded or something?


Now a lot of progress, but still 2 warnings at each useful line for pages:
- RecentChanges
- RecentlyCommented

RecentChanges wrote:Warning: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CST/-6.0/no DST' instead in /home/fb/public_html/wiki/actions/recentchanges.php on line 21

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CST/-6.0/no DST' instead in /home/fb/public_html/wiki/actions/recentchanges.php on line 21

Wed, 27 Feb 2013:

Warning: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CST/-6.0/no DST' instead in /home/fb/public_html/wiki/actions/recentchanges.php on line 28

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CST/-6.0/no DST' instead in /home/fb/public_html/wiki/actions/recentchanges.php on line 28

(00:32 CST) [history] - KeyPgMki ⇒ CountingPine
.....
fxm
Posts: 10046
Joined: Apr 22, 2009 12:46
Location: Paris suburbs, FRANCE

Re: The new website

Postby fxm » Mar 09, 2013 10:01

Always these two FBWiki pages polluted by warning messages as showed above!
Can you do something about it?
fxm
Posts: 10046
Joined: Apr 22, 2009 12:46
Location: Paris suburbs, FRANCE

Re: The new website

Postby fxm » Mar 11, 2013 17:24

fxm wrote:Always these two FBWiki pages polluted by warning messages as showed above!
Can you do something about it?

Thank you very much for removing these warnings.
This is much nicer now!
fxm
Posts: 10046
Joined: Apr 22, 2009 12:46
Location: Paris suburbs, FRANCE

Re: The new website

Postby fxm » Mar 30, 2013 10:47

fxm wrote:This link title (<View your posts>) could be at least changed to better match to its filtering behavior.
This dis-matching between the title and the command result is always here!

The present behavior corresponds to only filter the topics containing at least one of your posts.
counting_pine
Site Admin
Posts: 6237
Joined: Jul 05, 2005 17:32
Location: Manchester, Lancs

Re: The new website

Postby counting_pine » Mar 30, 2013 15:08

I think that's more an issue with phpBB.
fxm
Posts: 10046
Joined: Apr 22, 2009 12:46
Location: Paris suburbs, FRANCE

Re: The new website

Postby fxm » Mar 30, 2013 15:39

Under the <View your posts> button, there is no specific syntax for use with the FreeBASIC pages?

Return to “Community Discussion”

Who is online

Users browsing this forum: No registered users and 6 guests