Small, simple engine test, please test.

Game development specific discussions.
anonymous1337
Posts: 5494
Joined: Sep 12, 2005 20:06
Location: California

Postby anonymous1337 » Aug 13, 2007 18:25

Low frame rates and a tad laggy, but it worked. I am very confused by the configure, if only for the fact that I don't know what any of that stuff means ;_;

Erm, yeah some settings just wouldn't load. I don't know if they were in the process of doing so or what. Namely my native, 1280x1024 never loaded :-?

EDIT: Also, I couldn't help but replace your horrid texture for the ground with one of my own.

Image

His name is Steve. He's a Blalagaphlakasaurus, and he compresses quite well. If you want the texture file, go ahead and say so. Believe it or not, it actually looks quite well in game.

EDIT2: God damnit. I also forgot to mention that running off the edge puts me in an infinite "omg I am totally stuck here" space. Kinda like I'm standing in a box made of air. Perhaps the character is a mime? LOL.
Dr_D
Posts: 2396
Joined: May 27, 2005 4:59
Contact:

Postby Dr_D » Aug 13, 2007 18:38

Pritch, you really don't have to know what they mean. Everything is set from lowest quality to highest quality. So, if you go with lower setting, you'll have better performance.

Also, I was wondering if any of you tried to change the value in the gen.egs file in the data folder? I used 100 by default, which really is a bit high. You might try setting it to something <=10. I'm adding a culling routine so that it wont draw shadows for non-terrain objects that are too far away. Until then, setting the value in that file lower should help.
DaveUnit
Posts: 239
Joined: Apr 20, 2006 15:47
Location: Central MA
Contact:

Postby DaveUnit » Aug 13, 2007 20:07

I do get much better frames with very few objects but it really seems like the shadows really shouldn't eat as many frames as they do. maybe with that culling thing it'll help out a lot.
Deleter
Posts: 975
Joined: Jun 22, 2005 22:33

Postby Deleter » Aug 13, 2007 20:18

0 objects = 200+ fps

100 objects=20 fps
Dr_D
Posts: 2396
Joined: May 27, 2005 4:59
Contact:

Postby Dr_D » Aug 13, 2007 20:22

That's not bad really. It's somewhere around 175,000 polygons per fame, using 100 objects. ;)
Lachie Dazdarian
Posts: 2338
Joined: May 31, 2005 9:59
Location: Croatia
Contact:

Postby Lachie Dazdarian » Aug 13, 2007 21:22

I'm not sure if the new drivers helped, or your optimizations. I should check Sokoban 3D.

640*480 - Any combination gives 1-2 FPS, even when using the least demanding setting.

320*240 - I get 7 FPS. I tried all parameters and always get 7 FPS, unless I turn on the shadows (then 1 FPS). If I set the number in gen.egs to 10 I get whooping 34-41 FPS, which is great. Even if I put anti-aliasing 16x and texture filtering to LINE_MIP_LINE. Again, if turning shadows I get 1-2 FPS.

Anyway, I don't understand why 640*480 kills FPS so much.
vdecampo
Posts: 2982
Joined: Aug 07, 2007 23:20
Location: Maryland, USA
Contact:

Postby vdecampo » Aug 14, 2007 4:51

I'm getting the same peformance as Lachie. Very slow and jerky no matter what settings. Plus I am getting that "Z" error thing at the bottom.

P4 3.0e
1Gb RAM
ATI Radeon 9000

-Vince
Dr_D
Posts: 2396
Joined: May 27, 2005 4:59
Contact:

Postby Dr_D » Aug 14, 2007 4:59

Guys, zFail is a a method of producing shadow volumes. That's not an error. ;)
dav7
Posts: 64
Joined: Jul 31, 2006 21:27
Location: NSW, Australia
Contact:

Interesting, but...

Postby dav7 » Oct 22, 2007 14:52

Interesting engine.

On this 450MHz P3 with 320MB RAM and 4MB onboard video (S3 Trio3D), I get just over 1fps, with it at 320x480, color depth 8bpp, no antialiasing, no anisotropic filtering, shadows off, texture filtering at LINE_MIP_NEAR, the app windowed, and vertical sync off.

My "normal" box (2.66GHz P4 w/512MB, 256MB VRAM) is temporarily decomissioned until I can either get Linux, ReactOS or a legal XP key for it, so I'll post back if this thread is still active when that box is working again :D

-dav7

EDIT: Putting a "1" in gen.eds and setting Texture Filtering to NEAR -> MIPMAP OFF gives a small performance boost, and I'm actually able to use the game. It's probably running at 15fps or 18fps now, which is actually pretty good :D

I really think you should add a "toggle FPS" key to this thing by the way!

Return to “Game Dev”

Who is online

Users browsing this forum: No registered users and 3 guests