Small, simple engine test, please test.

Game development specific discussions.
Dr_D
Posts: 2396
Joined: May 27, 2005 4:59
Contact:

Small, simple engine test, please test.

Postby Dr_D » Aug 11, 2007 22:16

We're still doing testng to make these games run for more people with lower end pcs. If it doesn't run right, please report your gfx card/pc. Thanks. :)


http://file-pasta.com/d/1828.rar
Last edited by Dr_D on Aug 13, 2007 7:56, edited 2 times in total.
MichaelW
Posts: 3500
Joined: May 16, 2006 22:34
Location: USA

Postby MichaelW » Aug 11, 2007 23:45

Unless it was designed to lock my system up, it’s not working for me. After several trials the most likely looking thing I could get was a resolution change, then a full screen with “Z-Fail Shadow volume test.”

Windows 2000 SP4
P3-500
512 MB
Matrox G200 with the default drivers
SSC
Posts: 319
Joined: May 29, 2005 4:47
Location: Around
Contact:

Postby SSC » Aug 12, 2007 0:07

hmm, the link doesn't seem to be working for me but it may be because of my work's firewall. I'll check it out when I get home.
duke4e
Posts: 717
Joined: Dec 04, 2005 0:16
Location: Varazdin, Croatia, Europe
Contact:

Postby duke4e » Aug 12, 2007 1:02

works well.

dual core intel 1.8 GHz, nvidia 8500
1GB ram, win XP
Merick
Posts: 1038
Joined: May 28, 2007 1:52

Postby Merick » Aug 12, 2007 1:08

it runs ok for me, of course, with a 2gzh althon 64 and a radeon x1300 video card my system could hardly be called low-end

The only problems that I could see is that the camera movement is kinda jerky, looks almost like it's getting lag on the mouse input. Movement with the keyboard is smooth though.

Also, I don't know it's the way you intended it but the floor texture gets blurred out really close to the camera
diffeecult
Posts: 84
Joined: Feb 03, 2007 2:37

Postby diffeecult » Aug 12, 2007 1:16

Hmm. I don't understand. This runs great on my computer. Something ain't right. AMD Duron 900mhz - nvidia geforce fx 5200
1000101
Posts: 2556
Joined: Jun 13, 2005 23:14
Location: SK, Canada

Postby 1000101 » Aug 12, 2007 2:17

I'm getting upward of 200FPS on my main machine, however, as Merick said, the input is jerky (both keyboard and mouse for me).

On my TV computer (1.4GHz AthlonXP, Radeon 9000 Pro) it runs smoothly although the mouse input is a little lagged.
Dr_D
Posts: 2396
Joined: May 27, 2005 4:59
Contact:

Postby Dr_D » Aug 12, 2007 2:22

Thanks guys. I'm in the process of updating it now, where it uses glfw. Also, I made a nice newton character controller, which will allow for much better behavior.
Dr_D
Posts: 2396
Joined: May 27, 2005 4:59
Contact:

Postby Dr_D » Aug 12, 2007 4:45

Updated first post. Please try again. :)
Conexion
Posts: 236
Joined: Feb 23, 2006 6:04

Postby Conexion » Aug 12, 2007 5:47

Works great - “Z-Fail Shadow volume test.” << Get that though.

You may want to put the basic controls in the first post :P Took a sec to figure out and I'm too lazy to open a readme.txt :D

(of course, that's just me, so I'll just deal with it)

Pentium 4 - 2.8GHz
Windows XP Home
512 MB RAM
Intel 82915G/GV/910GL Express Chipset Family128.0 MB
anonymous1337
Posts: 5494
Joined: Sep 12, 2005 20:06
Location: California

Postby anonymous1337 » Aug 12, 2007 6:28

Works great here!

Pentium 4 - 2.8GHz
Windows XP Home Edition Service Pack Two Distributed by Microsoft Windows (c) - Microsoft Windows is a leading [...] thank you.
512 MB RAM
Intel 82865G Graphics Card - 96mb
Merick
Posts: 1038
Joined: May 28, 2007 1:52

Postby Merick » Aug 12, 2007 11:11

Mush better, looks like you fixed the input problem and the floor is no longer all blurry. Looks great at my monitor's max res of 1680x1050. Turning on the anti-aliasing option doesn't seem to do anything, but that's probably more because of the textures you're using than anything else
Lachie Dazdarian
Posts: 2338
Joined: May 31, 2005 9:59
Location: Croatia
Contact:

Postby Lachie Dazdarian » Aug 12, 2007 12:27

Erm...how do I acquire FPS of a program without an internal FPS counter?

I got probably the lowest configuration in here so you should probably ignore my report. Still, if curious...

In 640*480, 32-bit color depth and full screen I get less than 1 FPS.
In 320*240, 16-bit color depth and full screen around 3-5 FPS.

Anti-aliasing option doesn't seem to do anything with me too.

My specs:
Pentium III 866 Mhz
192 MB RAM
Windows XP
ATI 3D Rage PRO

What libs are you using but the Newton one?
1000101
Posts: 2556
Joined: Jun 13, 2005 23:14
Location: SK, Canada

Postby 1000101 » Aug 12, 2007 13:39

Conexion wrote:You may want to put the basic controls in the first post :P Took a sec to figure out and I'm too lazy to open a readme.txt :D


I just assumed being an "FPS" that is was mouse + WASD

btw, I get ~30 FPs at 1024x768 8x AA
sir_mud
Posts: 1401
Joined: Jul 29, 2006 3:00
Location: US
Contact:

Postby sir_mud » Aug 12, 2007 13:51

Lachie Dazdarian wrote:What libs are you using but the Newton one?

Knowing Dr_D its OpenGL.

Return to “Game Dev”

Who is online

Users browsing this forum: No registered users and 2 guests